Jump to content
  • Welcome to AutoLanka

    :action-smiley-028: We found you speeding on AutoLanka Forums without any registration! If you want the best experience, please sign in. Safe driving! 

Sign in to follow this  
lanka.deshan

Toyota Aqua Radiator fan not working

Recommended Posts

Posted (edited)

Hi All,

I have a toyota aqua 2013 model with milage ~50,000 km. 2 days ago  I noticed that car A/C not functioning properly.
And today the overheat indicator light shown for 2-3 seconds. Just after came home and I opened the engine compartment and noticed that radiator fan not running.
Then I fully turned on the A/C and checked again, still radiator fan not runniung.

So my question is, is it a known issue with toyota aqua?
What should I do now?

Edited by lanka.deshan

Share this post


Link to post
Share on other sites
Posted (edited)

Firstly I don't think your radiator fan could fail at 50,000km (I could be wrong). Check if the fuses are blown.

If it's not the fuse, it's probably a sensor

Edited by kadsa98

Share this post


Link to post
Share on other sites

Open rthe bonnet with the a/c on,.. and check the cooling  fan is working,.. and the free flow of air is not restricted,..

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Register for a new account in our community. It's easy and FREE!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  



×