Jump to content
  • Welcome to AutoLanka

    :action-smiley-028: We found you speeding on AutoLanka Forums without any registration! If you want the best experience, please sign in. Safe driving! 

  • 0
Ken c

Toyota mark 2 speedometer not working

Question

Please help. I have a 1996 Toyota mark 2 gx100 with a 1 g engine. My speedometer stopped working after leaving the car in the sun the whole day. It stated working again after putting it in a cool spot. But after a few days it stopped for good. The digital milage does not come on and it takes long to shift gears

Share this post


Link to post
Share on other sites

4 answers to this question

Recommended Posts

  • 0

Hi and welcome to AL.

Looks like the sun exposure finally has taken it's toll on your car.

You'll have to look for a re-co dash instrument cluster.

 

Share this post


Link to post
Share on other sites
  • 0
Posted (edited)

Hi. But does the dashboard also affect the delay in gear shift?

Edited by Ken c

Share this post


Link to post
Share on other sites
  • 0

Can you note down all the problems you face?

Share this post


Link to post
Share on other sites
  • 0

Milage display off, Speedometer not working, gears take long to change. 

They are no codes on the ECT or ABS

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Register for a new account in our community. It's easy and FREE!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now



×