Jump to content
  • Welcome to AutoLanka

    :action-smiley-028: We found you speeding on AutoLanka Forums without any registration! If you want the best experience, please sign in. Safe driving! 

  • 0
MNI

Engine knocking when accelerating in Honda Fit GE6 Non Hybdrid

Question

I have a honda fit GE6 with a millage of 69500km.I have done the services on time.But from last week noticed engine jerks/knocks when accelerating but in lower speeds and idle its smooth.

Please enlighten me on this problem and how to solve it

I didn't use the car for about 1 week. When I stopped the car fuel level was almost empty. Then I started it and went to the fuel station.Can this cause any injector blocks from dirt from fuel tank. This is the only mishsp prior to the problem. Please I need your expert opinion

 

Thanks

Share this post


Link to post
Share on other sites

6 answers to this question

Recommended Posts

  • 0

Yesterday my engine check light was blinking and did a engine scan to find out 4th cylinder was not firing.When the plugs were checked 4th plug was not even removed for the matter cleaned during the previous tune up.Which was done in a garage down syvester road Mount lavinia who is a real cheater Without doing a proper job he sent me to Nilwala motors to repair the gear box.The crook wasted my time and mobey. After cleaning the plugs and tune up car is completely fine.

  • Like 1

Share this post


Link to post
Share on other sites
  • 0

Can't be dirt due to multiple fuel filters in between the fuel tank and injectors!

 

Sounds like a coil pack issue. would be better to take it to a good mechanic.

Share this post


Link to post
Share on other sites
  • 0

Thanks Is there anyone around Dehiwela who is good to show 

Share this post


Link to post
Share on other sites
  • 0
On 1/7/2019 at 8:34 PM, MNI said:

I have a honda fit GE6 with a millage of 69500km.I have done the services on time.But from last week noticed engine jerks/knocks when accelerating but in lower speeds and idle its smooth.

Please enlighten me on this problem and how to solve it

I didn't use the car for about 1 week. When I stopped the car fuel level was almost empty. Then I started it and went to the fuel station.Can this cause any injector blocks from dirt from fuel tank. This is the only mishsp prior to the problem. Please I need your expert opinion

 

Thanks

As a general rule keep in mind to never run on lower fuel levels or an empty tank. Its better to spend an extra 1500 bucks to fill up more juice than to replace your fuel pump in a while.

The reason behind it is due to the lower fuel quality in the local market. This has many impurities and when you run on an empty tank the fuel pump will keep pulling out this crap to the system and thus busting your pump over time while your engine will also clog up the junk along the long run to give you a lesser fuel efficiency. 

Another good rule is to listen for the buzz of the fuel pump starting up when your key is in the On position/ push start 1 press. This helps the fuel pump start up and supply a good flow as you start up the engine for your run.

And its always a good idea to tone your driving pattern, Since you are using a CVT it will keep shifting to higher gears as you speed up. and if you suddenly start slowing down/braking and accelerating again, The CVT will keep shifting to a lower gear and then back to a higher gear or at times depending on the load it might stay at a higher gear than required. This change in gears usually causes a jerk/knocking sensation and is quite normal for an averagely older petrol car. 

When i was overseas i left my nissan sunny i used to have unattended for nearly 5 months and it worked fine so leaving a car without using is not the case but the general maintenance and running cycle along with your driving pattern.

If you havent done a tuneup in a while, Try getting one done and it might boost up your engine performance along with a better fuel economy and better gear changes as your engine will not run too lean or too rich. 

PS- I'm no expert so anyone feel free to correct any discrepancies in my advise!

Share this post


Link to post
Share on other sites
  • 0

Thanks for your ideas I did an engine tune up and a scan.Engine runs very smoothly in idle. But still the problem exists.The fellow who did it told there's an issue with the gear shifting.Anyway I have done gear oil changing on time with recommended oil.Now a little worried.When the gear is in sports mode shifting is smoother and there's no slipping of gear on slopes even in D.

  • Like 1

Share this post


Link to post
Share on other sites
  • 0

Yesterday my engine check light was blinking and did a engine scan to find out 4th cylinder was not firing.When the plugs were checked 4th plug was not even removed for the matter cleaned during the previous tune up.Which was done in a garage down syvester road Mount lavinia who is a real cheater Without doing a proper job he sent me to Nilwala motors to repair the gear box.The crook wasted my time and mobey. After cleaning the plugs and tune up car is completely fine.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Register for a new account in our community. It's easy and FREE!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now



×