Jump to content
  • Welcome to AutoLanka

    :action-smiley-028: We found you speeding on AutoLanka Forums without any registration! If you want the best experience, please sign in. Safe driving! 

Recommended Posts

Work in progress. Cleaning the valves and polishing rocker arm shafts.

udz8JSF.jpgCvMn68Y.jpgeRgELjb.jpglOL9LtR.jpgi0HOu7p.jpg

Edited by varotone
added pics
  • Like 2

Share this post


Link to post
Share on other sites

My engine bores need honing. I'm waiting till I get a free day to take it to the machine shop. Had a close look at the carburetor and kind of disappointed.

 

There are cracks near the carburetor mounting bolts, EGR lines are clogged up, a coolant line to the carb is broken and sealed. The carb needs a lot of work. Also, the carb is "Aisan". I gather that the original was "Solex" manufactured by "Mikuni". I have 4 options to fix this mess.

1. Search for a carburetor expert who can refurbish this one. (Neeyourou help to find one)

2. Buy a reconditioned carb from a scrap yard. (Didn't go hunting for one. But my mechanic says it will be available)

3. Buy a brand new Japanese carb (the most expensive option. Mikuni goes for about $250 on eBay. Didn't find any here)

4. Buy a brand new Thaiwan / Chinese carb (readily available here. 4 places had them. Goes for 15-20k)

I would like to know your thoughts on this.

ig8Teo3.jpg

6OaWYjC.jpgmAu4rhM.jpg

Added

Following some older threads on AL, I called Dhammika at Kotta rd. To discuss my options. He says he doesn't do carb overhaul. Does only tuning. He told me to contact Shantha. (He clearly said he can't recommend the guy. But he does carb overhauls.) Found that Shantha runs the Carburetor Banda's place in Grandpass and doesn't have good reviews on AL. So, I'm back at square one. Looking at how rare carb mechanics are I'm seriously considering learning carburetor repairs myself.

Edited by varotone
Added content

Share this post


Link to post
Share on other sites

HELP NEEDED

I have some basic questions and at this point I'm too afraid to ask.

1. What engines came with this car? YOM 1983. (According to my manual, it was manufactured with 4G3 series and 4G5 series engines.)

2. My engine number starts with G12B-CB-XXXX. What engine do I have? I believe it's 4G12B. 1400cc Orion with jet valves.

3. How can I find out what engine it had when it was manufactured? And know if it was swapped later on? (I just want to know if the current engine is the same model as it was designed to fit. I'm alright if a previous owner had replaced it with one of same model)

 

4. Does anyone have a engine repair manual for my engine? (I remember seeing a large collection of Lancer manuals somewhere on AL. But a search didn't show the ones I need)

Share this post


Link to post
Share on other sites
13 hours ago, varotone said:

1. What engines came with this car? YOM 1983. (According to my manual, it was manufactured with 4G3 series and 4G5 series engines.)

In Sri Lanka the 1400cc 4G12 (Orion engine. Referred to by some mechanics as "Orient engine") and the 4G33 (Saturn engine) were the most popular. I believe I have seen a couple of early model A72 Lancers with 1200cc 4G36 engines, but are rare. Then we've got the very rare GSR that came with a 1600cc 4G32 engine. The GSR is the first gen Lancer responsible for many world  rally victories, putting the "Mitsubishi" name in the map of world rallying. There are a couple of 2 door Lancer GSRs in the country.

13 hours ago, varotone said:

2. My engine number starts with G12B-CB-XXXX. What engine do I have? I believe it's 4G12B. 1400cc Orion with jet valves.

That is correct. Your engine is the most common one that came on these cars.

13 hours ago, varotone said:

3. How can I find out what engine it had when it was manufactured? And know if it was swapped later on?

If the book has been updated, I don't think you can. There might be a digit in the chassis number that corresponds to the engine model that was installed on the car. You'll have to find a chassis number decoder and see if that'll work, but I doubt these old chassis numbers work with them.

13 hours ago, varotone said:

4. Does anyone have a engine repair manual for my engine?

This is the manual for 4G3 carb series. The 4G1 series carb manual is abit hard to find. So maybe you can use this for now as they are very similar. 

http://mitsubishi-motors.kiev.ua/Manuals/Engine/pwee9049/11A.pdf

  • Thanks 1

Share this post


Link to post
Share on other sites

HELP NEEDED

This is the thermo regulator relay that controls the AC. This was disconnected. AC compressor clutch was wired separately with a switch to keep the AC working. I want to test this relay and use this. Because the wiring is badly hacked, I'm lost not knowing where these wires connect to.

Please help me with connecting this properly. My mechanic wants to toss this away and use a manual thermostat. Google didn't help finding wiring diagram.oAOddtb.jpgeYNpLQb.jpg

3ybDiaV.jpg

Edited by varotone
Added pics

Share this post


Link to post
Share on other sites
On 2/18/2019 at 12:39 AM, varotone said:

My engine bores need honing. I'm waiting till I get a free day to take it to the machine shop. Had a close look at the carburetor and kind of disappointed.

 

There are cracks near the carburetor mounting bolts, EGR lines are clogged up, a coolant line to the carb is broken and sealed. The carb needs a lot of work. Also, the carb is "Aisan". I gather that the original was "Solex" manufactured by "Mikuni". I have 4 options to fix this mess.

1. Search for a carburetor expert who can refurbish this one. (Neeyourou help to find one)

2. Buy a reconditioned carb from a scrap yard. (Didn't go hunting for one. But my mechanic says it will be available)

3. Buy a brand new Japanese carb (the most expensive option. Mikuni goes for about $250 on eBay. Didn't find any here)

4. Buy a brand new Thaiwan / Chinese carb (readily available here. 4 places had them. Goes for 15-20k)

I would like to know your thoughts on this.

ig8Teo3.jpg

6OaWYjC.jpgmAu4rhM.jpg

Added

Following some older threads on AL, I called Dhammika at Kotta rd. To discuss my options. He says he doesn't do carb overhaul. Does only tuning. He told me to contact Shantha. (He clearly said he can't recommend the guy. But he does carb overhauls.) Found that Shantha runs the Carburetor Banda's place in Grandpass and doesn't have good reviews on AL. So, I'm back at square one. Looking at how rare carb mechanics are I'm seriously considering learning carburetor repairs myself.

What ever you do, you'll need a carb overhaul kit for that . Also note your carb is off a Toyota.

Also keep in mind that what ever you do, you'll have to get your car tom pass the emissions test when you get it on the road,..

Edited by Twin Turbo

Share this post


Link to post
Share on other sites

MITSUBISHI RE 72826 A THERMO RELAY

Finally figured out the wiring for this. I've hastily drawn the wiring diagram on MS paint. This thermo-relay uses a Mitsubishi M51202 IC OPamp as a voltage comparator to compare the potential difference between the NTC resistor used as a sensor and a rheostat used to set the temperature. If the potential difference across the NTC resistor is higher than the potential difference across the rheostat, the AC relay is energized by the output voltage. Here are the wiring diagrams, pinouts, and schematics for the IC. 

In my case, the unit was faulty due to a blown Zenner. Replacing it solved the issue. Looks like Mitsu L200 and L300 has the same unit.

ZRDtunj.png4qvofBt.pngBmqJOcr.pngdXwtbq6.pngZDmlhDO.png 

  • Like 3

Share this post


Link to post
Share on other sites

Persistence does pay off. Well done @varotone

  • Thanks 1

Share this post


Link to post
Share on other sites

My rear brakes self adjusting mechanism is worn out. I remember this being discussed before in this forum. However, I couldn't find it now. Please share how to fix this. Is there a permanent fix for this?

Share this post


Link to post
Share on other sites
15 hours ago, varotone said:

My rear brakes self adjusting mechanism is worn out. I remember this being discussed before in this forum. However, I couldn't find it now. Please share how to fix this. Is there a permanent fix for this?

Yeah this is a common issue. The easiest solution would be to fill up the self adjusting mechanism and cut the grooves on it so that it doesn't slip. But this is a lot of work and won't be a permanent solution as the metal used to fill the groove will not be as strong as the cast metal of the part. 

The more expensive, but reliable thing to do would be to find rear brakes from a Lancer Box. It will fit perfectly and the handbrake adjuster mechanism on the Box is different and doesn't wear out like the one on the A72. Finding one however will be difficult. 

Share this post


Link to post
Share on other sites

Thanks for the suggestion. I deepened the grooves on the existing adjusting mechanism. Instead of filling the worn grooves and cutting I just deepened the existing ones and filled the opposite side so that the thickness of the metal remains unchanged in the end. I hope this will last a little longer than filling the worn side. At least till I find parts from a box.

Do I need to buy the whole rear brake assembly or just the adjuster mechanism that fits on to the brake shoes?

Share this post


Link to post
Share on other sites
7 hours ago, varotone said:

Thanks for the suggestion. I deepened the grooves on the existing adjusting mechanism. Instead of filling the worn grooves and cutting I just deepened the existing ones and filled the opposite side so that the thickness of the metal remains unchanged in the end. I hope this will last a little longer than filling the worn side. At least till I find parts from a box.

Do I need to buy the whole rear brake assembly or just the adjuster mechanism that fits on to the brake shoes?

Yep, deepening the grooves also works, but I found that the mechanism sometimes slips and disconnects. This happens especially if you have the brake pedal depressed while pulling the parking brake. 

As for your question, the adjuster mechanism on the Box doesn't fit the A72. It's a totally different (and better) design. So you will have to swap the entire assembly out with the brake dial plate. 

Share this post


Link to post
Share on other sites

Sadly, I couldn't attend to the project lately. Body work was completed some time ago in my absence. Shiny paint is now under a layer of dust. Soon I'll start assembling the car and post few photos on the progress.

  • Like 1

Share this post


Link to post
Share on other sites

I'm stuck at connecting the fuel lines. On either sides there are two small tank thingies - fuel vapor separators. Each has 3 connections. But in the right hand side, the rubber grommet has holes for only 2 fuel lines. Confused how to connect these fuel lines.

I've made marks with tipp-ex on the fuel lines before I remove them. Now that all the marks are sanded and painted over😬. There's a diagram in the workshop manual but it confused me more.

 

Anyone can remember how to connect them?

Share this post


Link to post
Share on other sites
10 hours ago, varotone said:

I'm stuck at connecting the fuel lines. On either sides there are two small tank thingies - fuel vapor separators. Each has 3 connections. But in the right hand side, the rubber grommet has holes for only 2 fuel lines. Confused how to connect these fuel lines.

I've made marks with tipp-ex on the fuel lines before I remove them. Now that all the marks are sanded and painted over😬. There's a diagram in the workshop manual but it confused me more.

 

Anyone can remember how to connect them?

I could remove and reconnect them with my eyes closed back in the day. But my memory has failed me after all these years. 

May I suggest getting help from a fellow A72 owner and checking how they're connected on their car?

Hoping to see photos of the finished paint job! 🙂

Share this post


Link to post
Share on other sites

I want to replace the timing belt tensioner pulley because it is noisy. I'm trying to replace only the bearing because the pulley itself looks good. But because of the way it's attached to the mounting bracket it seems impossible to push out the bearing with a hydraulic press. Any suggestions on how to proceed? Or should I replace the whole pulley mechanism?

h9TodLk.jpgVkcqrVF.jpg

Share this post


Link to post
Share on other sites
10 hours ago, varotone said:

I want to replace the timing belt tensioner pulley because it is noisy. I'm trying to replace only the bearing because the pulley itself looks good. But because of the way it's attached to the mounting bracket it seems impossible to push out the bearing with a hydraulic press. Any suggestions on how to proceed? Or should I replace the whole pulley mechanism?

h9TodLk.jpgVkcqrVF.jpg

Simple answer, replace the entire unit.

As a failure of this will damage the Tbelt.

  • Like 1

Share this post


Link to post
Share on other sites
17 hours ago, varotone said:

I want to replace the timing belt tensioner pulley because it is noisy. I'm trying to replace only the bearing because the pulley itself looks good. But because of the way it's attached to the mounting bracket it seems impossible to push out the bearing with a hydraulic press. Any suggestions on how to proceed? Or should I replace the whole pulley mechanism?

Yes, replace the entire thing. It isn't that expensive. 

  • Like 1

Share this post


Link to post
Share on other sites
Posted (edited)

Thank you for your advice.

(For a moment I forgot how common this engine is and worried about finding the exact part😬)

So here's what I did today.

Parts list. All OEM. Price in LKR.

1. Timingbelt tensioner razor 2500

2. Timing belt 1800

3. Alternator belt 600

4. Ac belt 550

5. Oil filter 760

6. Havoline 15w-40 4L 4000

I swapped the belts, tensioner, oil filter and filled her up. Fired up the engine 😅. It ran smooth for a couple of minutes and then this happened☹️

(Sorry for not keeping the thread updated. Engine was rebuilt and broken into in my absence. Belts and tensioner were not replaced after the rebuild.)

There is a loud high pitched noise depending on the rpm. It only exists within a narrow range of rpm. When I started the car today morning I heard the same noise for a short time. I tried to replicate the noise without success. So I gave up the idea of investigating it and went ahead with the belt swap hoping the noise is a squeaky belt.

Now the noise is heard persistently throughout a range of rpm. Here's a video clip including the noise.

https://imgur.com/a/c0sCr81

Any suggestions on troubleshooting?

 

Edited by varotone
Broken link

Share this post


Link to post
Share on other sites
Quote

Good work bro, wrote the milage and date of the car on the timing case if you got the  sticker.

On 4/16/2020 at 12:44 AM, varotone said:

I want to replace the timing belt tensioner pulley because it is noisy. I'm trying to replace only the bearing because the pulley itself looks good. But because of the way it's attached to the mounting bracket it seems impossible to push out the bearing with a hydraulic press. Any suggestions on how to proceed? Or should I replace the whole pulley mechanism?

h9TodLk.jpgVkcqrVF.jpg

Simple answer, replace the entire unit.

As a failure of this will damage the Tbelt.

Share this post


Link to post
Share on other sites
On 4/16/2020 at 10:33 PM, varotone said:

Thank you for your advice.

(For a moment I forgot how common this engine is and worried about finding the exact part😬)

So here's what I did today.

Parts list. All OEM. Price in LKR.

1. Timingbelt tensioner razor 2500

2. Timing belt 1800

3. Alternator belt 600

4. Ac belt 550

5. Oil filter 760

6. Havoline 15w-40 4L 4000

I swapped the belts, tensioner, oil filter and filled her up. Fired up the engine 😅. It ran smooth for a couple of minutes and then this happened☹️

(Sorry for not keeping the thread updated. Engine was rebuilt and broken into in my absence. Belts and tensioner were not replaced after the rebuild.)

There is a loud high pitched noise depending on the rpm. It only exists within a narrow range of rpm. When I started the car today morning I heard the same noise for a short time. I tried to replicate the noise without success. So I gave up the idea of investigating it and went ahead with the belt swap hoping the noise is a squeaky belt.

Now the noise is heard persistently throughout a range of rpm. Here's a video clip including the noise.

https://imgur.com/a/c0sCr81

Any suggestions on troubleshooting?

 

That sounds like a bearing to me. Maybe over-tensioned drive belts? A good test would be to loosen or completely take out the accessory belt that drives the AC compressor. If that doesn't solve it, loosen or completely take out the main drive belt and run the car for a short time.

If it's none of those, it might be the water pump.

You may have already done this because you have the manual, but I have to ask... did you tighten the tensioner and other bolts to spec?

Share this post


Link to post
Share on other sites

I've tried running without the AC compressor belt. It made no difference. Next tried removing the alternator/water pump belt for a short time. Could not replicate the noise within that short period. (I'm a bit nervous about running the engine for long without the water pump spinning).

For good measure checked the timing belt tension again and found it to be within speck: 5 to 7mm. Alternator belt tension also adequate: 7 to 9mm. But when spinning the alternator by hand there was minimal noise. So I dissembled the alternator and replaced the bearings.

I didn't put back the AC compressor belt yet. Still there's the noise but now for very short duration and quite difficult to replicate. Lasts for a very short time. Not enough time to locate from where the noise is coming from.

I have tried spraying water on the belts to see if it disappears. Checked vacuum lines for leaks, anything that may be running on the spinning belts. Found none of them.

 

Speaking of torquing down the bolts to specs🤦‍♂️ After seeing that the repair manual giving torque specs for almost all the bolts (including buffer, seats, steering wheel...) I bought a 'digital toque wrench adaptor' online. I being penny-wise ordered the cheapest one I could find with the maximum torque range without bothering about the seller's rating. It never arrived, no refund. Penny wise pound foolish me is now without a torque wrench 😂

So, all the bolts with high torque such as mounting bolts are tighten to the maximum with a socket wrench and cheater bar. (My mechanic torqued the innards of the engine. No worries there☺️)

In hindsight I should have bought a quality torque wrench from a local tool shop. But the range is limited and costs a lot. The digital toque adapter would still be the best bang for the buck

  • Like 2

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.




×
×
  • Create New...