Jump to content
  • Welcome to AutoLanka

    :action-smiley-028: We found you speeding on AutoLanka Forums without any registration! If you want the best experience, please sign in. Safe driving! 

Jbreak

Toyota Aqua 2015 dashboard indicator

Recommended Posts

Service required indicator. The most common reason it seems to come on (according to user manual) is when the Hybrid system's cooling system has an issue. It could be as simple as the vents for the battery getting clogged. So look around a bit and then take it to a proper Hybrid service center or the agents.

The error was discussed before on the forums...perhaps you can dig it up again ?

  • Like 1

Share this post


Link to post
Share on other sites
Just now, iRage said:

Service required indicator. The most common reason it seems to come on (according to user manual) is when the Hybrid system's cooling system has an issue. It could be as simple as the vents for the battery getting clogged. So look around a bit and then take it to a proper Hybrid service center or the agents.

The error was discussed before on the forums...perhaps you can dig it up again ?

Thanks IRage.To be honest I searched it but didn’t come across anything related to this.Anyways appreciate  ya help!

Share this post


Link to post
Share on other sites

Check the user manual. Page 344 to be exact. That is where I found it the first time someone asked it on the forum and on FB. The description is in Japanese but you can use the Google translator phone app to translate it.

  • Like 1

Share this post


Link to post
Share on other sites
59 minutes ago, iRage said:

Check the user manual. Page 344 to be exact. That is where I found it the first time someone asked it on the forum and on FB. The description is in Japanese but you can use the Google translator phone app to translate it.

Thanks a lot for the info mite

Share this post


Link to post
Share on other sites
50 minutes ago, SalmanAhmedKhan said:

Toyota Aqua 2015   showing this sign and the engine sign. Any know what dose this mean🤔

IMG-20180701-WA0000.jpg

This has been discussed

http://autolanka.com/forums/topic/17074-dashboard-warning-light/?do=findComment&comment=280219

Share this post


Link to post
Share on other sites
On 7/3/2018 at 12:17 AM, SalmanAhmedKhan said:

 

On 7/3/2018 at 12:17 AM, SalmanAhmedKhan said:

 

Hi Salman,

 

The indicator shows that you need attention with Hybrid battery. Take the car to a proper technician and run a scan on battery. You will be able to get an idea how many cells needs replacement. (Toyota Aqua 2012 has 20 cells in its hybrid battery and as per what i was told by the tech guy we can replace cells if the replacement is for less than 10 cells, More than that he recommended to replace the full battery. This is never recommended by the agent and they would ask you to replace the battery with new one.)

I also have a 2012 and 6 months ago i too had the same problem (Found many Aqua's having the same issue once it pass 5 year mark or 100,000 mileage in common) . I replaced 7 cells in the battery and driving my car for past 6 months without an issue. I know its not a permanent solution but so far it has worked.

 

 

 

 

Share this post


Link to post
Share on other sites

I saw an advertisement. Toyota Lanka is doing Hybrid Battery replacement. Cant remember the prices though.

Share this post


Link to post
Share on other sites
On 7/4/2018 at 9:42 AM, Jbreak said:

Hi Salman,

 

The indicator shows that you need attention with Hybrid battery. Take the car to a proper technician and run a scan on battery. You will be able to get an idea how many cells needs replacement. (Toyota Aqua 2012 has 20 cells in its hybrid battery and as per what i was told by the tech guy we can replace cells if the replacement is for less than 10 cells, More than that he recommended to replace the full battery. This is never recommended by the agent and they would ask you to replace the battery with new one.)

I also have a 2012 and 6 months ago i too had the same problem (Found many Aqua's having the same issue once it pass 5 year mark or 100,000 mileage in common) . I replaced 7 cells in the battery and driving my car for past 6 months without an issue. I know its not a permanent solution but so far it has worked.

 

UPDATE 11th July 2018: Had the same issue on Friday, 6th July 2018 and replaced four cells again the following day.First repair in Nov,2017 cost me Rs.58,000 (Rs.7000/- a cell + Rs.9000 for tech charges which was done manually.). This time the cost was Rs.49,000 at Rs.8500 /- a cell + Rs.15,000 (For electronically balancing the battery). I've been using the car since Aug, 2015 and do regular services with the agents. This was the only problem i had in 3 years and unfortunately for me its the battery.

 

 

 

Edited by Jbreak

Share this post


Link to post
Share on other sites

So, @Jbreak what you say is you have replaced cells for the second time in 6 months? Is that right? Also how many other users do you think are affected like this?

Share this post


Link to post
Share on other sites
2 hours ago, Crosswind said:

So, @Jbreak what you say is you have replaced cells for the second time in 6 months? Is that right? Also how many other users do you think are affected like this?

Hi @Crosswind Yes, You are right. I have basically replaced 11 cells of my battery.There are two others i know who has the same problem with their 2012 & 2014 YOM's. With the recent post published here there's four including myself

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Register for a new account in our community. It's easy and FREE!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now



×