Jump to content
  • Welcome to AutoLanka

    :action-smiley-028: We found you speeding on AutoLanka Forums without any registration! If you want the best experience, please sign in. Safe driving! 

  • 0
Mokip

Suzuki Rs 2017 highbrid steering rack noise and play

Question

Has anybody using the  suzuki rs 2017 model e experience the above issue please share your thoughts and how to fix it  or advice.

 

Any recommendations please ?

Share this post


Link to post
Share on other sites

Recommended Posts

  • 0
On 3/28/2018 at 9:38 AM, thirtyone said:

Hi,

I also have started experiencing the same problem. The noise started at around 4600+ Kms. 

Was anybody able to find what causes this and what the repair is like?

Hi, did you get the rack noise fixed?

Share this post


Link to post
Share on other sites
  • 0
1 minute ago, PrasadDHL said:

Did u get the rack noise fixed?

it was fine for sometime and the noise is back. I checked with A*W as per them ppl complain the same with grand vitara as well it seems. so what they are saying is, our road conditions are not compatible with the variable rack system what RS has. no solution so far.

Share this post


Link to post
Share on other sites
  • 0
7 minutes ago, PrasadDHL said:

Hi, did you get the rack noise fixed?

Hey Prasad,

I took it to Sterling Aftercare as one of the other members had recommended. They took a look at it, and the actual noise is coming from the steering column than the rack itself. They removed the column from inside the driver's side, and what they could make of it was that it needs replacing, and what they understood is when the column turns it grinds a little with the steering column covering.

They lubricated the column, and told that it might fix it, or it might come again, and probably with time it'll wear off the area that it grinds and it'll stop making the noise.

However after they put together the whole thing back, it didn't make any noise until a week or so, and now I rarely hear it sometimes. Bottomline is I chose to ignore it as I don't see replacing the part isn't going to fix it if it's a dimensional issue on the steering column they make.

I've uploaded a pic of the part (steering column) i'm referring to.

Regards.

s-l300.jpg

  • Like 1

Share this post


Link to post
Share on other sites
  • 0
6 minutes ago, thirtyone said:

Hey Prasad,

I took it to Sterling Aftercare as one of the other members had recommended. They took a look at it, and the actual noise is coming from the steering column than the rack itself. They removed the column from inside the driver's side, and what they could make of it was that it needs replacing, and what they understood is when the column turns it grinds a little with the steering column covering.

They lubricated the column, and told that it might fix it, or it might come again, and probably with time it'll wear off the area that it grinds and it'll stop making the noise.

However after they put together the whole thing back, it didn't make any noise until a week or so, and now I rarely hear it sometimes. Bottomline is I chose to ignore it as I don't see replacing the part isn't going to fix it if it's a dimensional issue on the steering column they make.

I've uploaded a pic of the part (steering column) i'm referring to.

Regards.

s-l300.jpg

Thanks bro. 

  • Like 1

Share this post


Link to post
Share on other sites
  • 0
22 minutes ago, shanjeevanm said:

it was fine for sometime and the noise is back. I checked with A*W as per them ppl complain the same with grand vitara as well it seems. so what they are saying is, our road conditions are not compatible with the variable rack system what RS has. no solution so far.

Thanks.

Share this post


Link to post
Share on other sites
  • 0

Hello everybody.

My name is Gonzalo and i am from Uruguay, in south america.

I own a 2016 zc32s swift sport with 11.900km.

In that time i had 3 steering racks replaced and one steering column replaced.

I know people from Mexico, Chile, Australia, Malaysia and Japan suffering from a lot of steering rack problems with the swift from all versions.

Next monday i am geting my car the 2 years service at the dealer and i will request for a 4th time steering rack replacement.

The new model (base and sport) also suffer from this issue, have a look at this video.

https://www.youtube.com/watch?v=GsNPROxmJAg&list=FLeVAALd7IvF940YTbW43wwg&t=0s&index=26

I can't believe suzuki is unable to produce a decent quality  rack, these problems has been part of the swift since the 2005 model...

  • Like 2
  • Sad 1

Share this post


Link to post
Share on other sites
  • 0

I can't believe Suzuki still have this issue on their cars. From my experience on Suzuki Racks most of time fault is with steering column (Intermediate Shaft)  see my previous post on this 

In this case as thirtyone's post it will also with steering column (Intermediate Shaft) my experience with 2003 Suzuki Cruze but on 2017 Swift?. It will definitely steering column (Intermediate Shaft). on the tie rack wears it self it can be replaced or repaired but it will not solve the noise you have to repair shaft also.

in my case as above my previews post shaft replacing didn't solve the problem. few weeks later noise came back and i have repaired it again. I think this is their manufacturing fault. 

 

Share this post


Link to post
Share on other sites
  • 0
Posted (edited)

my steering column (upper and lower joints/shafts) were replaced once, when car only was 190km...

since then there has been no problem with those.

but the steering rack.... thats another story, has been replaced 3 times.

and today took it to the dealer asking for a 4th time but they said that that level of noise/play is normal and wont replace it again.

so i will have to wait a few more month until play gets worse and hopefully they will replace it then,

the new swift and swift sport zc33s are also suffering from column and rack problems.

the car in the video i posted previously is a 2018 zc33s swift sport with 8000km......

Edited by gonzagnr

Share this post


Link to post
Share on other sites
  • 0

Anyone found a solution yet to the steering column rubbing noise ?

Share this post


Link to post
Share on other sites
  • 0
Posted (edited)
18 minutes ago, Shez said:

Anyone found a solution yet to the steering column rubbing noise ?

It's not a major issue as compared to the noise. I had it checked, it's the column that rubs against its housing. There is no issue with the rack end.

The noise comes and goes every once in a while in mine.  Nothing much to worry about!

Cheers.

Edited by thirtyone

Share this post


Link to post
Share on other sites
  • 0

Thanx thirtyone for the prompt reply appreciate it very much!

Share this post


Link to post
Share on other sites
  • 0
1 hour ago, thirtyone said:

It's not a major issue as compared to the noise. I had it checked, it's the column that rubs against its housing. There is no issue with the rack end.

The noise comes and goes every once in a while in mine.  Nothing much to worry about!

Cheers.

I got mine checked. Its the issue with the rack. There are multiple issues related to the rack in suzuki some have issues in the steering column some at the rack end some at the rack itself identify your issue correctly thru reliable mechanics. 

Share this post


Link to post
Share on other sites
  • 0
21 hours ago, shanjeevanm said:

I got mine checked. Its the issue with the rack. There are multiple issues related to the rack in suzuki some have issues in the steering column some at the rack end some at the rack itself identify your issue correctly thru reliable mechanics. 

Did you get yours sorted out ?and if so what was wrong and where did you get it done

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Register for a new account in our community. It's easy and FREE!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now



×