Jump to content
  • Welcome to AutoLanka

    :action-smiley-028: We found you speeding on AutoLanka Forums without any registration! If you want the best experience, please sign in. Safe driving! 

  • 0
petrolHead1

Suzuki Japan Alto Suspension Issue

Question

Hi all, 

My Japanese alto gave a slight clicking sound when turning the steering wheel (to the left) and accelerating. This sound was diagnosed as a CV joint failure by my mechanic. Therefore, we replaced the entire left side shaft along with the inner and outer CV joints. Brand new CV joints were not available and had to settle with second hand Japanese parts from Delkanda. However the sound was not sorted out. After another trip to the garage, the right shaft , joints and rack boots were replaced. This also resulted with no improvement of the sound. 

Now the odd part is that the mechanic is now suspecting a bush of the AT gear box as the cause. He is saying that I have to replace the entire gearbox in the worst-case-scenario. Have you guys experienced this type of an issue? If so, how do you diagnose this?

Share this post


Link to post
Share on other sites

2 answers to this question

Recommended Posts

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.




×
×
  • Create New...