Jump to content
  • Welcome to AutoLanka

    :action-smiley-028: We found you speeding on AutoLanka Forums without any registration! If you want the best experience, please sign in. Safe driving! 

  • 0
Sign in to follow this  
cefiroA33

Gear Changing Issue

Question

Hi there members,

After a long time and hope you guys are keeping well.

I had a slight issue with my Nissan Cefiro A33 yesterday and I hope you guys can help me sort it out.

Yesterday I was travelling to Kandy from Colombo when suddenly I felt that the gears are not shifting smoothly. This happend when I was passing Pasyala area after starting the journey from Moratuwa. For a certain period of time gears were not shifting eventhough the RPM raised. Then I stopped at a nearby garage and since it wasn't open I had to wait for like 20 minutes until the mechanics come and the car engine had been stopped.

When the mechanics start the test drive there wasnt any issue of shifting gears and all were ok. So again I started with the journey and continued until Kegalle when the gear shifting again started failing. Then again I stopped the car for a while and after few minutes rest the problem sorted. I parked the car at a friends house in peradeniya and came back to colombo by bus.

Guys My periodic service is due and also I have run for like 25,000 km from my last ATF change. Can you guys advice me on this issue.

Thanks and best regards,

Share this post


Link to post
Share on other sites

6 answers to this question

Recommended Posts

  • 0

The first thing you should do is get an ATF oil change. This is the first step of diagnosing many automatic transmission problems. From your description, it does sound like an oil change will solve the issue.

  • Like 1

Share this post


Link to post
Share on other sites
  • 0

Thanks davyy. Another thing i realised is that this issue always came when I was climbing up the hill. No issue when travelling in the flat terrain

Share this post


Link to post
Share on other sites
  • 0

It could be that your transmission is heating up. If changing oil doesn't fix it. Try checking if the gearbox has a heat exchanger attached to your radiator. It might be blocked (there should be 2 oil lines from the gearbox going to it).

Edited by c1nder
  • Like 1

Share this post


Link to post
Share on other sites
  • 0

Start with ECU scan - if any error codes track down.

like Davy said ATF oil change must at this point

  • Like 1

Share this post


Link to post
Share on other sites
  • 0

Thanks guys for your valuable comments. I have booked an appointment at A*W on tuesday for a scan. if it doesnt indicate any error hoping to take the car to Nilwala motors for an inspection. will keep you posted

Share this post


Link to post
Share on other sites
  • 0

guys, today i took my car to A*W and after a scan they diagnosis the issue as transmission output sensor failure. So the sensor is being replaced.

However during the scan they also identified an issue with the ignition coils. What I was told is that six coils needs to be replaced. However because of the massive estimate I didnt want to do it at this stage. So can anyone reccommend me a good place to have a look at my engine and ignition coils at a reasonable price.

Regards

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Register for a new account in our community. It's easy and FREE!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  



×