Jump to content

Search the Community

Showing results for tags 'ge6'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • AUTOLANKA
    • General Automotive
    • News & Updates
    • Feedback & Suggestions
    • DIY (Do-It-Yourself)
    • User Manuals & Service Manuals
    • BLOGS
  • ASK AN EXPERT
    • Mechanical problems
    • Electrical problems
    • General
    • Car Buying Information
  • MOTORING EVENTS
    • Local Events
    • International Events
  • OTHER
    • PC and other Console Games
    • The Lounge
  • SPECIFIC MAKES
    • HONDA SRI LANKA
    • SUBARU
    • MITSUBISHI
    • NISSAN
    • TOYOTA
    • MAZDA
    • BMW
    • MERCEDES BENZ
    • MINI (CLASSIC & NEW)
    • PERODUA
    • PEUGEOT
    • OTHERS
  • OUTDOOR 4X4
    • General
    • Events
    • Trips
  • LEGAL
    • Ask for Advice
    • Share Advice
    • General

Calendars

  • AutoLanka Calendar
  • Southern Motor Sports Club's Events

Blogs

There are no results to display.

There are no results to display.


Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


Location


Interests


Vehicle Make


Vehicle Model


Engine Type


Mechanical Mods


Cosmetic Mods


Future Plans


General Comments

Found 2 results

  1. Niranjana Fernando

    Engine Oil for Honda Fit GE6

    What is the suitable engine oil for Honda Fit GE6 2010?
  2. I have been using a Honda FIT GE6 2009 Petrol Car for several years now and its almost 94,000 Kms on the odometer. Few months back car starts to knock (unsure this is the right term to describe the issue) starting at 1500 and goes away if I push the accelerator down or up a bit. If I keep the paddle in 1500 RPM the knock keeps continuing. Most of the time it starts knocking 1500 RPM and around 40Km/h but on highway or freeways happens on 70-80Km/h. Also this is quite noticeable as its shaken the whole car. This issue starts only after engine is getting hot. When I starts the car in the morning it runs very smooth but after driving around 10-15 minutes above symptoms starts. And also after a long trip like 4-5 hours of continuous driving car really hesitates to drive up hill. If I push the accelerator down, engine starts rev up without moving forward and after 2-3 seconds it starts moving smoothly. First thought this is a gearbox issue and changed CVT as well as added CVT conditioner from BG. Nothing changed and then did a full engine tune up (cleaning complete fuel system including petrol pump). Finally cleaned and replaced the EGR valve with a reconditioned one but no luck so I fixed my original EGR back. No error codes or no CEL. Also the engine mounts are in good condition. I have checked my plugs and injectors from two mechanics and both mentioned no need of changing them. If you guys can please share your thoughts here, that would be really helpful.
×