Jump to content

Sanjeewa_Wijetunge

Members
  • Content Count

    5
  • Joined

  • Last visited

Community Reputation

0 Neutral

About Sanjeewa_Wijetunge

  • Rank
    Newbie

Profile Information

  • Gender
    Male

My Vehicle Details

  • Vehicle Make
    Nissan
  • Vehicle Model
    FB 15
  1. Sanjeewa_Wijetunge

    Nissan FB 15 ECU Problem

    Hi Guys, Yesterday I went to the agent and got it scanned again through the Nissan Consult 2 scanning system... Believe it or not it was not the ECU that is having the problem, it is the Ignition coils that is faulty. After the scanning it showed error code "P1320" which is related to Ignition coils. So A*W asked me to replace all 4 ignition coils. I'm confused because at Auto Miraj when they scanned it showed error in the 'ECM - Engine Control Module". Here it showed it is the ignition coils. At A*W, one ignition coil costs Rs 16,000.. Anybody have an idea how much it will cost if I can buy it from outside?
  2. Sanjeewa_Wijetunge

    Nissan FB 15 ECU Problem

    Yes the car is hesitating to start in the morning (Cold Start) but starting without any problem in the hot start. Also accelartion is not very good (pulling power). Yes they reset the error codes and scanned the 2nd time also. Still the same error in "ECM" is coming.
  3. Sanjeewa_Wijetunge

    Nissan FB 15 ECU Problem

    No, they didn't give me any printed reports since it was a quick scan. Yes, the car start and running without any issues. Also the ABS warning is also indicating in the dashboard.
  4. Sanjeewa_Wijetunge

    Nissan FB 15 ECU Problem

    Dear Guys, My car is Nissan FB 15 and since yesterday the engine check light is indicating from time to time. So today I went to Auto Miraj and connected to a scanner and checked. According to the scanner, it shows the fault in "ECM - Engine Control Module" Does this mean the car's ECU is Faulty?? Also kindly provide me a reliable person who can repair ECU faults. Thanks.
  5. Sanjeewa_Wijetunge

    Nissan FB 15 Issue

    Hi, I have a Nissan FB 1999 model. When I start the car and starts moving slowly there is a "grrrrr" like vibration coming from the engine for a like 2 seconds. After that I don't hear that noise until I start the car next time and starts moving again. Also when I press the brake, it is also getting locked and a "grrrrr" noise coming from the brake padal. When I release the brake and press on the padal again, its all normal and i can drive for whole day without that issue happening again. These 2 issues only happens when I start the car and starts moving only. What could be the issue???
×