Jump to content

PerfMad

Members
  • Content Count

    358
  • Joined

  • Last visited

  • Days Won

    6

PerfMad last won the day on August 26 2019

PerfMad had the most liked content!

Community Reputation

113 Good

2 Followers

About PerfMad

  • Rank
    Member

Profile Information

  • Gender
    Male
  • Interests
    Automobiles, photography, computers, gaming

My Vehicle Details

  • Vehicle Make
    Honda
  • Vehicle Model
    City 2001/ FitAria 2004
  • Engine Type
    1500CC

Recent Profile Visitors

12,298 profile views

Single Status Update

See all updates by PerfMad

  1. Couldn't start my car for almost 2-3 weeks since i wasn't at home.. However, i got a chance to start it yesterday and i let it idle for 10 mins after starting. Car started at first attempt and cold start idle was at the correct RPM as well. After about 10 minutes rpm started to fluctuate 1000-2000 .. but when i keep the throttle steady to 2000 or more it doesnt do it. it only happens in idle. before quarantine there was no such issue.

    could this be a clogged IACV, throttle body? what should i look into? have my ECo test pending so i have to attend to this within next week and get it sorted by any means.

    1. Show previous comments  3 more
    2. Kavvz

      Kavvz

      You're welcome to bring the car over to my place of course, no worries... But I'm sure you can rev it out just as well as I can! 😄

    3. PerfMad

      PerfMad

      lol yeah.. actually i had a carb cleaner bottle around. so i cleaned the throttle body and didnt have time to clean the injectors. therefore i did good 2-3 pulls in second gear with 7000 rpm and now all idle issues are gone and its back to normal :D 

    4. Kavvz

      Kavvz

      There you go! :D

×
×
  • Create New...