Jump to content

mightymicra

Members
  • Content Count

    21
  • Joined

  • Last visited

Community Reputation

0 Neutral

About mightymicra

  • Rank
    Newbie

Recent Profile Visitors

631 profile views
  1. mightymicra

    BMW 316 M10 Wont Start

    Good Morning Rumesh, First, Thank you for being so helpful in this regard. Yes I have already checked the connections and voltage for to the CDI and seems ok. And yes I did remove the plug wires and tested through the main lead (I forgot to take out the spark plugs and thank you for reminding me). There was a spark suddenly which ended up shocking me also . then nothing. When I was checking through the connections only wired thing I noticed was one pin connection from the CDI to the ignition coil was not the way it states. But if I were to change it seems a whole change in the wiring needed to be done. The surprising thing was the car was running in this setup before (assuming the garage guy did not mess with it) so I was not encouraged to change it. (I did not wanna burn the CDI, where I have no idea if that is fried already as well.). However I will be getting a distributor this week hopefully and will fix it and let you know the update. Thanx again..have a great day..and I wish to submit some pics so you will get the idea more clearly. Cheers !!!
  2. mightymicra

    BMW 316 M10 Wont Start

    Hii Rumesh, Nop the carb swap was not done as that guy was just dragging the things and then the car was towed here. We are waiting to get it fired up so we can do the swap. So as you think this could be mainly the problem ryt ? I am not a great expert on these but climbing my way through interesting projects like these. Once again thank you very much for your help in this regard. appriciate it. Cheers !!!
  3. mightymicra

    BMW 316 M10 Wont Start

    Hiii.. Thank you for the reply. Yes I checked the resistance of the pulse generator coil and it seems to be correct. And the clip I mentioned is the one below the dust cover which leads to the CDI Unit. Yep also regarding the gap. The manual has mentioned you need to replace this plate if it was bent while dissembling. Seems to be that the plate is bent and the gaps are wrong. (Manual says 3mm gap). I cleaned all the parts (It was full of gunk) and before this when I cranked the AC voltage is between 0.5v - 0.7v and the manual state is should be 1.0v - 2.0v. . When I removed it and cleaned it and testing by rotating by hand it showed 1.0v - 1.2v ut it was quite fast I guess. When you put it back n when the engine cranks it bit slower and I guess this is the reason this does not generate the required voltage. Is there any place we can get the spare distributor and check ? Thank you in advance.
  4. mightymicra

    BMW 316 M10 Wont Start

    Hiii, Its been a very long time since I v last been here. I have came across a friend's car, A BMW 316 M10 (Carburetor) model. This car has been running ok and then was put to a garage where he wanted to do a carburetor swap. However things did not ended as planned and the car was sitting there with nothing and finally when he wanted it back the guy at the garage has said its not starting. My friend did not want to keep the car there anymore so we had to tow it back. Anyhow when we went there and asked the guy what might have been gone wrong he pointed some clip was broken in the distributor and this should be the problem. We towed it back to my place and then started to fix the broken clip. Still with no luck the car is not giving any spark. I was managed to get a workshop manual and checked the wiring and seems everything in order. This is a DCI model and there is a pulse generator in the distributor and my suspicion was this could be the problem. (The manual sates that if you remove the distributor assembly you might need to replace the signal plate "Which trigger the AC signal to the CDI"). So I know there are many experts with great knowledge in here and I would be glad if you could help me out with this to bring the beast back to life. (I am not an expert but trying to work my way up). So Thank you in advance to whole who can give me tips and ideas what should be done. Cheers !!!!
  5. mightymicra

    Toyota Lh 51 Auto Gear Problem

    Helloo guys..thank you very much for all the comments.."Davy" yes sorry about the "ETC" thing..it was the switch but pressing it or releasing it does not help. and "Stig" n "John" yes I can move the stick in to other positions from D to 2 to L (1) ..problem is it does not move in any forward positions. It ll kick in as soon as you put it in to "R". if you wanna move forward you just have to toggle within the gears and accelerate a bit high n hope for the best n it ll suddenly jump and start to go. and the fault will not occur for the rest of the day even longer period. This comes and goes. My guess is also it might be the forward clutch. the engine is in kind a bad shape..so hoping to do a complete swap..but I do not know it ll be soon. So just in case keep the ideas and comments flowing in guys. Thank you for the support..
  6. mightymicra

    Toyota Lh 51 Auto Gear Problem

    Hello guys....wow its been a very long time since I last came here...just need a lil help from the experts.. My friend has a Toyota LH 51 super custom which has an auto gear box. It has a problem where sometimes when you put it in to "D" position it does not move at all. But as soon as you put in to "R" it moves..but does not move in a single forward positions. Well checked the gear oil and seems to be at the level..but I think the "ETC" light is also on. Can this be the issue. Guys can you please help me with this ?? Thank you in advance
  7. mightymicra

    Alto K10 Ignition Key

    Hey VVTI thnx...Yeah that what I was also thinking. it actually worked last time. I was thiking more decent way ....hey "hrm" mentioned about this transmitter. But it is a very small piece and do not see any kind of circuitry or anything like that. so I am not sure what is exactly there. Nways thnx for the comments guys. more comments are welcome : ) Cheers
  8. mightymicra

    Alto K10 Ignition Key

    Hey All, One of my friends have an Alto K10 (Maruti) and recently he broke the key. So we got a new key cut but could not start from it. Then when we check inside the plastic part of the original key we found a small magnet like piece but I am sure is is not magnet. Anyhow we found out that if we bring it (the plastic part of the key) considerably close to the keyhole and start the car it will start. So my question is does anyone know the mechanism of this function ? is there any way we can bypass this ?? Appreciate your comments. Thank You
  9. Hey guys its been a long time since I posted something in here. here is what I need guys.. may be some of you remember I have a march K10. and um hoping to put an "oil cooler" for that. Well most of you would think what a stupid idea but I need you guys openion on this. their are few problems in my mind now. 1) It was a compitition oil cooler (just a replacement for existing one so didnt came with the kit). So I am missing few parts like the oil lines and the "oil cooler sandwich". The person I bought it from said he will help me to get through this but he dsnt seem to hv an idea too. any how I managed to find a guy who could make the custome oil lines for it. So that is solved. 2) Oil cooler sandwich. Do any of you happen to know where I could get one of this or at least make one ? I guess there are universal adapters. I looked in "ebay" still I prefer to findsmthing from here so its more risk free. 3) Since this engine did not have an oil cooler originally and if I put this system in ..will it drop the oil pressure in the system and ruine the engine. Actually most of all I need the ans for this specially. I do not wanna ruine poor buddys heart. Well i appreciate your comments guy. Thank you.
  10. Hey Iroshw its probably sound like the ignition coil..You could find a reconditioned one usually we call it "Bothal Coil" which is good or you can replace it with an electronic one..But using the latter is recommended. Also I guess your distributor has "Contact Point" (Usually found inside the distibutor). See if the "Capacitor" is good. Otherwise even you change the coil thisg would come up soon after.. let us know the progress.. Cheers Bro...
  11. mightymicra

    Hyundai Elantra 2000 - Engine Problem

    Hellooo Guys, Thank you all for the comments and advises. I went through it in the weekend and It wasnt bad as I thought it would be. I came across the problem as soon as I removed the top cover. I noticed that power conntetor to one ignition coil was damaged and it has disconnected. This was the cause to not to fire the two cylinders. When I check the connectes they were badly degraded and became dust as soon as I touched them . I removed the connecters and plugged them only with the metal pinns. (This is temporary, have to find a connector or a wire harness that could replace this). Anyhow now the engine is firing all cylinders. Yet, it still has the rough idle issue, and the low milage issue. Hope to have some ideas from you guys to clear out these problems also. Thnx
  12. mightymicra

    Hyundai Elantra 2000 - Engine Problem

    Rumesh...Yeah my thought was same...nways we cannot judge a mechanic at a glance and I also do not have huge experaince on EFI. How ever thank you for all who gave thair comments. I will start by cheking spark plugs and wires. I mean by "Heat Indicator" is the water temperature. It did not seem to go beyond the "half" level but I felt resonable maount of heat aroung the glove box and the shifter. May be it isnt directly related to the fault. I mentioned them just to see it would ring a bell to someone. Thank you for you all again..Please keep posting and I will also let you know on the progress. Since this happend yesterday I will start diagnosting probably from tomorrow. May be "crosswind" have more opinions ??? Regards.
  13. mightymicra

    Hyundai Elantra 2000 - Engine Problem

    Thank you very much for the start off...yeah I wm waiting for others openions also. I did not post all the story since it will be bored and some may be even wont read it. I will let you all know the symptoms one by one as the discussion goes on. One time he took the car to a machanic and he cleaned the fule pump and the oxygen sensor and also said that he has reprogrammed it and changed some chip (This I have some doubt). How ever the problem dissapeared along with the check engine light. but the light cam up few days later and the worst case happend yesterday as I mentioned earlier. Hope you guys have more ideas with this issue. Thanx again..
  14. mightymicra

    Hyundai Elantra 2000 - Engine Problem

    Hellooo Guys, Its been some time since I have posted a problem. My friend has a Elantra 2000 model and its has not been in a good running condition since i have known. Its milage is somewhat lower than usual. He is not much of a car guy and he has been taking it to every one suggested anything and spent heaps and still having the problems. Hope you guys will have some answers on this. I am really keen to help him on this. Ok. Here is the problem. 1) It has a starting problem. in Cold start first time starts for a second and stalls. Then second time it starts fine. 2) there is a vibration after starting and in few seconds it somes to a decent idle state. 3) The big problem started yesterday when it was drving fine but suddenly stopped. It was hard to start. Even when started there is a huge shake and sounds like its working on 3 cylinders. There is a major loss in power also. Hear indicator is normal but the interior keeps up heating (I do not know if this is related to the latter problem). 4) In the above case the RPM rarely go above 2000 and the "Check Engine" light keeps flashing. Can you guys please give me an idea to start with this ??? Thanx......
  15. mightymicra

    Good Place To Tune A Carb

    Hey guys, I have a nissan march K10. Recently I started a restoration project and as metioned in another topic of mine and with the comments of you all I stated "de-ricing" it. But I have a small problem with its carb since back then. So you guys know a good place to do a tuning job coz I know if its tuned well it can do way more better than you expect. So please help me on this.. Thanx...
×